What browsers are supported?

All modern browsers that understand HTML 5 - IE 9, Firefox 11, Safari 5, Chrome 17 and above. But we put effort into being downward compatible. Please make sure that you always use the latest version of your preferred browser.

Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.
Powered by Zendesk